Manual browser: isset(9)
|SETBIT(9)||Kernel Developer's Manual||SETBIT(9)|
NAMEsetbit — macros related to bitmaps
DESCRIPTIONThe setbit family of macros operate with bitmaps, also known as bit arrays.
In a nutshell, setbit() sets the bit x in array, clrbit() clears it, isset() tests whether x is set, and isclr() returns 1 if x is not set.
EXAMPLESThe following example declares a buffer of 10 chars, treating it as an array of 80 bits:
char buf; ... setbit(buf, 12); /* set the fifth bit in the second byte */
CAVEATSThe number of valid bits in a given array is assumed to be multiple of CHAR_BIT, the number of bits for smallest object that is not a bit-field.
|December 4, 2012||NetBSD 7.0|