Kernel Developer's Manual
NAME lock, simple_lock_init, simple_lock, simple_lock_try, simple_unlock, simple_lock_freecheck, simple_lock_dump, lockinit, lockmgr, lockstatus, lockmgr_printinfo, spinlockinit, spinlockmgr — kernel lock functions
These interfaces have been obsoleted and removed from the system.
Please see the condvar(9), mutex(9), and rwlock(9) manual pages for information on kernel synchronisation primitives.
HISTORY The kernel locking API first appeared in 4.4BSD-lite2, and was replaced in NetBSD 5.0.