Manual browser: proc_find(9)
|PROC_FIND(9)||Kernel Developer's Manual||PROC_FIND(9)|
NAMEproc_find, pgrp_find — find process or process group
struct proc *
struct pgrp *
extern kmutex_t *proc_lock;
DESCRIPTIONThe proc_find() and pgrp_find() functions retrieve process and process group structures from process ID pid and process group ID pgid. Both functions must be called by holding a mutex(9) on proc_lock.
RETURN VALUESUpon successful completion, the described functions return a pointer to either struct proc or struct pgrp. Otherwise, if the requested ID was not found, NULL is returned.
|July 1, 2010||NetBSD 7.0|