Manual browser: rootconf(9)
|CPU_ROOTCONF(9)||Kernel Developer's Manual||CPU_ROOTCONF(9)|
NAMEcpu_rootconf, rootconf, setroot — root file system setup
setroot(device_t bootdv, int bootpartition);
DESCRIPTIONThe cpu_rootconf() is a machine-dependent interface invoked during system bootstrap to determine the root file system device and initialize machine-dependent file system state. cpu_rootconf() provides the global variables booted_device, booted_partition, booted_startblk, and booted_nblks and invokes the machine-independent function rootconf which rootconf then calls the function setroot to record the boot/root device and the boot partition information for use in machine-independent code.
For disk boot, if booted_nblks is not 0, then booted_startblk and booted_nblks are supposed to specify a disk wedge that is used as the root device. Otherwise the booted_partition is used.
|July 29, 2012||NetBSD 7.0|