Manual browser: adbkbd(4)
|ADBKBD(4)||Kernel Interfaces Manual||ADBKBD(4)|
NAMEadbkbd — support for ADB keyboards
SYNOPSISadbkbd* at nadb?
wskbd* at adbkbd? console ? mux 1
wsmouse* at adbkbd?
DESCRIPTIONThe adbkbd driver handles most ADB keyboards within the wscons(4) framework. It also provides an interface to translate key strokes to mouse button events.
Which keys are translated to mouse button events can be configured for each individual keyboard via sysctl(8):
- Controls which scan code is used for middle mouse button events. Default is 103, which corresponds to F11.
- Controls which scan code is used for right mouse button events. Default is 111, which corresponds to F12.
SEE ALSOnadb(4), wskbd(4), wsmouse(4), wsconsctl(8), wskbd(9)
|May 14, 2007||NetBSD 7.0|