Manual browser: bthub(4)
|BTHUB(4)||Kernel Interfaces Manual||BTHUB(4)|
NAMEbthub — Bluetooth Remote Device Hub
SYNOPSISbthub* at bcsp?
bthub* at bt3c?
bthub* at btbc?
bthub* at btuart?
bthub* at sbt?
bthub* at ubt?
bthidev* at bthub?
btmagic* at bthub?
btsco* at bthub?
DESCRIPTIONThe bthub device is used to attach remote Bluetooth devices to the system, and will attach to Bluetooth controllers as they are enabled.
CONFIGURATIONNormally, Bluetooth Remote Devices will be configured on the bthub using the btdevctl(8) program, which passes a proplib(3) dictionary to the control file /dev/bthub with the BTDEV_ATTACH and BTDEV_DETACH ioctl(2) commands.
The following properties are used by bthub:
- Local BD_ADDR. This required property should be a six byte data blob.
- Remote BD_ADDR. This required property should be a six byte data blob.
Service name. This required property should be a string indicating the service to configure, and may be one of the following:
- Handsfree, see btsco(4).
- Human Interface Device, see bthidev(4).
- Headset, see btsco(4).
Properties used by the configured device are listed in the appropriate device manual page.
SEE ALSObluetooth(4), bthidev(4), btmagic(4), btsco(4), btdevctl(8)
HISTORYThe bthub driver was written by under the sponsorship of Itronix, Inc. and first appeared in NetBSD 4.0.
|October 17, 2010||NetBSD 7.0|