Manual browser: btdevctl(8)
|BTDEVCTL(8)||System Manager's Manual||BTDEVCTL(8)|
NAMEbtdevctl — Bluetooth remote device control utility
|btdevctl||[-A | -D] [-qv] [-m mode] -a address -d device -s service|
DESCRIPTIONThe btdevctl utility is used to configure bluetooth devices in the system. Normally, btdevctl will perform an SDP query to the remote device as needed, and cache the results in the /var/db/btdevctl.plist file for later use. If neither Attach nor Detach is specified, btdevctl will display the configuration.
The options are:
- Attach device
- -a address
- Remote device address. The address may be given as BDADDR or a name. If a name was specified, btdevctl attempts to resolve the name via bt_gethostbyname(3).
- Detach device
- -d device
- Local device address. May be given as BDADDR or device name.
- -m mode
Connection link mode. The following modes are supported:
- clear previously set mode.
- require devices be paired, see btpin(1).
- auth, plus enable encryption.
- encryption, plus change of link key.
When configuring the HID service, btdevctl will set ‘auth’ by default, or ‘encrypt’ for keyboard devices. If the device cannot handle authentication, then the mode will need to be cleared manually.
- Ignore any cached data and perform a SDP query for the given service.
- -s service
Service to configure. Known services are:
- Human Interface Device.
- Be verbose.
For device configurations to persist across boots, add entries to the /etc/bluetooth/btdevctl.conf file and set the rc.conf(5) variable btdevctl to YES.
EXIT STATUSThe btdevctl utility exits 0 on success, and >0 if an error occurs.
SEE ALSObtpin(1), bthidev(4), bthub(4), btsco(4), rc.conf(5)
See the Bluetooth chapter of “The NetBSD Guide” for detailed examples of configuring keyboards, mice, and audio headsets.
HISTORYParts of the btdevctl program originated in the FreeBSD bthidcontrol program.
AUTHORSfor Itronix, Inc. <email@example.com>
|December 26, 2012||NetBSD 7.0|