Manual browser: cas(4)
|CAS(4)||Kernel Interfaces Manual||CAS(4)|
NAMEcas — Cassini/Cassini+ (GigaSwift) Ethernet device driver
SYNOPSIScas* at pci? dev ? function ?
Configuration of PHYs may also be necessary. See mii(4).
DESCRIPTIONThe cas driver provides support for the Sun Cassini and Cassini+ (GigaSwift) and the National Semiconductor Saturn Ethernet hardware found in Sun UltraSPARC machines and Sun GigaSwift PCI cards.
Cards supported by this driver include:
- Sun Gigaswift Ethernet (SX fibre variants)
- Sun Gigaswift Ethernet (UTP variants)
- Sun quad Gigaswift Ethernet
SEE ALSObrgphy(4), gentbi(4), gphyter(4), ifmedia(4), intro(4), mii(4), ifconfig(8)
Sun Microsystems, Cassini+ ASIC Specification, http://www.sun.com/processors/manuals/cs_plus.pdf.
HISTORYThe cas driver first appeared in OpenBSD 4.1. NetBSD support was added in NetBSD 6.0.
AUTHORSThe cas driver was written for OpenBSD by <firstname.lastname@example.org>, based on the gem(4) driver, and ported to NetBSD by <jdc@NetBSD.org>.
BUGSThe cas driver does not support any of the advanced features of the Cassini chip.
On the SX fibre variants of the hardware, the link may stay down if media options apart from autoselect are chosen.
|January 7, 2010||NetBSD 7.0|