Manual browser: com(4)
|COM(4)||Kernel Interfaces Manual||COM(4)|
NAMEcom — serial communications interface for RS-232C
SYNOPSIScom0 at isa? port "IO_COM1" irq 4
com1 at isa? port "IO_COM2" irq 3
com* at acpi?
com* at cardbus?
com* at isapnp?
com* at mca? slot ?
com* at mhzc?
com* at ofisa?
com* at pcmcia?
com* at pcmcom?
com* at pnpbios? index ?
com* at puc? port ?
com* at xirc?
Amigacom* at clockport?
Arm32com0 at mainbus? base 0x00210fe0
com1 at mainbus? base 0x00210be0
HP 9000/300 and 400 Seriescom* at dio? scode ?
com* at frodo? offset ?
HP 9000/700 and 800 Seriescom* at dino?
com* at gsc?
com* at ssio?
IBM PowerPC 4xxcom* at opb?
SPARCcom* at ebus?
com* at obio0
x68kcom0 at intio0 addr 0xefff00 intr 240
com1 at intio0 addr 0xefff10 intr 241
DESCRIPTIONThe com driver provides support for NS8250-, NS16450-, and NS16550-based EIA RS-232C (CCITT V.28) communications interfaces. The NS8250 and NS16450 have single character buffers, and the NS16550 has a 16 character buffer.
Input and output for each line may set to one of following baud rates; 50, 75, 110, 134.5, 150, 300, 600, 1200, 1800, 2400, 4800, 9600, 19200, 38400, 57600, or 115200, or any other baud rate which is a factor of 115200.
The ttyXX devices are traditional dial-in devices; the dtyXX devices are used for dial-out. (See tty(4).)
options COM_HAYESP adds support for the Hayes ESP serial board.
options PPS_SYNC enables code to use the Data Carrier Detect (DCD) signal line for attachment to an external precision clock source (e.g., GPS, CDMA) which generates a Pulse Per Second (PPS) signal. This is used by ntpd(8) to discipline the system clock, and more accurately count/measure time. See options(4) for more discussion.
With options RND_COM enabled, the com driver can be used to collect entropy for the rnd(4) entropy pool. The entropy is generated from interrupt randomness.
Arm32 specificIf “flags 1” is specified, the com driver will not set the MCR_IENABLE bit on the UART. This is mainly for use on AST multiport boards, where the MCR_IENABLE bit is used to control whether or not the devices use a shared interrupt.
- com%d: %d silo overflows
- The input “silo” has overflowed and incoming data has been lost.
- com%d: weird interrupt: iir=%x
- The device has generated an unexpected interrupt with the code listed.
SEE ALSOacpi(4), ast(4), cardbus(4), isa(4), isapnp(4), mca(4), mhzc(4), ofisa(4), options(4), pcmcia(4), pcmcom(4), pnpbios(4), puc(4), rtfps(4), tty(4), xirc(4), ntpd(8)
HISTORYThe com driver was originally derived from the HP9000/300 dca driver.
BUGSData loss is possible on busy systems with unbuffered UARTs at high speed.
The name of this driver and the constants which define the locations of the various serial ports are holdovers from DOS.
|April 29, 2012||NetBSD 7.0|