Manual browser: fujhk(4)
|FUJBP(4)||Kernel Interfaces Manual||FUJBP(4)|
NAMEfujbp, fujhk — Fujitsu Brightness, Pointer, and Hotkeys
SYNOPSISfujbp* at acpi?
fujhk* at acpi?
DESCRIPTIONSome Fujitsu laptops come with vendor-specific ACPI devices to manage the laptop hotkeys (such as the ‘Eco’ button), and to control various built-in components (such as the display, the touchpad, and the speakers). The fujbp and fujhk drivers provide support, through these ACPI devices, for hotkeys, backlight on/off switch, brightness level control, and pointer on/off switch.
The following sysctl(8) read/write variables are provided (when hardware support is available):
- Brightness level (integer).
- Pointer switch state (boolean).
- Backlight switch state (boolean).
Please note, however, that future versions of the drivers may remove these sysctl(8) variables without prior notice.
SEE ALSOacpi(4), acpivga(4), sysctl(8), pmf(9), sysmon_pswitch(9)
HISTORYThe fujbp and fujhk drivers appeared in NetBSD 6.0.
CAVEATSBrightness level and backlight switch state should be controlled via wsconsctl(8) instead of sysctl(8).
The sysctl(8) variable hw.acpi.fujbp0.pointer should be replaced by a platform-independent userland control.
|February 20, 2011||NetBSD 7.0|