Kernel Interfaces Manual
NAME mcp980x — Microchip 9800/1/2/3 I2C temperature sensor driver
SYNOPSIS mcp980x* at iic? addr 0x48
driver provides support for the MCP980x series of temperature sensors. It allows reporting ambient temperature through the envsys(4)
The following sysctl(3)
variable are provided:
ADC resolution (integer). Valid values are 0-3, where 0 is 9-bit (0.5 Celsius degree) and 3 is 12-bit (0.0625 Celsius degree) resolution.
If the ambient temperature exceeds this limit, the chip asserts an alert line (integer).
Hysteresis for temperature limit (integer).
HISTORY The mcp980x device first appeared in NetBSD 7.0.
MCP9805 chip is different and is supported by the sdtemp(4)
The MCP980x chip supports hysteresis and temperature limit values with a resolution of 0.5 Celsius degree, however the mcp980x driver supports setting only integer values.