Manual browser: njata(4)
|NJATA(4)||Kernel Interfaces Manual||NJATA(4)|
NAMEnjata — Workbit NinjaATA-32 CardBus IDE controller driver
SYNOPSISnjata* at cardbus? function ?
njata* at cardbus? function ? flags 0x01 # with wait 0x01
DESCRIPTIONThe njata driver provides support for the following Workbit Bus-Master CardBus IDE controller chips:
- CardBus / PCMCIA dual mode IDE controller (“DuoATA”). This controller is mainly used for portable drives. This driver supports the CardBus mode.
- CardBus IDE controller. This controller is widely used for CardBus CompactFlash adapters.
These controllers are capable of bus-mastering for ATA PIO transfer. The njata driver uses the bus-mastering PIO transfer unless transfer buffer is unaligned, and significantly reduces CPU usage for PIO-only ATA devices compared with usual PIO transfer.
CONFIGURATIONThe optional flags parameter is the “wait” value for ATA transfers. Some combinations of host and device may fail without flags parameter or flags 0x00. In this case try adding wait values like flags 0x01 or flags 0x11 (the wait parameter is composed of two 4bit values). Smaller wait values should be faster. Too long waits may cause transfer errors.
HISTORYThe njata device driver first appeared in NetBSD 4.0.
|September 7, 2006||NetBSD 7.0|