Manual browser: uscanner(4)
|USCANNER(4)||Kernel Interfaces Manual||USCANNER(4)|
NAMEuscanner — minimal USB support for scanners
SYNOPSISuscanner* at uhub?
DESCRIPTIONThe uscanner driver provides minimal support for USB scanners. The driver recognizes a number of USB scanners, but to actually scan anything there needs to be software that knows about the particular scanner. The SANE package provides support for some scanners.
HARDWAREThe uscanner driver works with the following scanners:
- Perfection 610U
- Perfection 636U
- Perfection 1200U
- Perfection 1200U Photo
- Perfection 1260
- Perfection 1660
- Perfection 2400
- ScanJet 4100C
- ScanJet 5200C
- ScanJet 6300C
Many other scanners are recognized, but there is no software support for them yet.
SEE ALSOscanimage(1), usb(4), usscanner(4)
USB Scanners under Linux, http://www.buzzard.org.uk/jonathan/scanners-usb.html.
HISTORYThe uscanner driver appeared in NetBSD 1.6.
BUGSThis driver should not really exist. The scanners it recognizes can be accessed through the ugen(4) driver instead. A proper scanner driver would provide a uniform interface to scanners instead of exposing the innards of the scanner. The reason the driver exists is to have something that is compatible with the Linux driver.
|September 10, 2000||NetBSD 7.0|