Manual browser: virtio(4)
|VIRTIO(4)||Kernel Interfaces Manual||VIRTIO(4)|
NAMEvirtio — Para-virtualized I/O in a virtual machine
SYNOPSISvirtio* at pci? dev ? function ?
ld* at virtio?
vioif* at virtio?
viomb* at virtio?
DESCRIPTIONvirtio defines an interface for efficient, standard and extensible I/O between the hypervisor and the virtual machine. The virtio device driver represents an emulated PCI device that the hypervisor makes available to the virtual machine.
virtio driver itself provides the core infrastructure to communicate with the hypervisor (called virtqueues) and supports the following devices:
SEE ALSOld(4), pci(4), vioif(4), viomb(4)
Rusty Russell, IBM Corporation, Virtio PCI Card Specification, http://ozlabs.org/~rusty/virtio-spec/.
HISTORYThe virtio driver first appeared in NetBSD 6.0.
|November 5, 2011||NetBSD 7.0|