Manual browser: wmihp(4)
|ACPIWMI(4)||Kernel Interfaces Manual||ACPIWMI(4)|
NAMEacpiwmi — Windows Management Instrumentation support for ACPI
SYNOPSISacpiwmi* at acpi?
wmidell* at acpiwmibus?
wmieeepc* at acpiwmibus?
wmihp* at acpiwmibus?
wmimsi* at acpiwmibus?
DESCRIPTIONThe acpiwmi device driver provides an ACPI interface for Windows Management Instrumentation (WMI). The ACPI WMI interface is typically used to support vendor specific features found in various laptops.
The following WMI mappings are supported:
- Dell laptops
- Some models of Asus Eee PC
- Hewlett-Packard laptops
- MSI laptops
The functionality varies from vendor to vendor. Typically the interface is used for function and hotkey handling, but additional features may be present.
SEE ALSOacpi(4), acpidalb(4)
Microsoft Corporation, Windows Instrumentation: WMI and ACPI, http://www.microsoft.com/whdc/system/pnppwr/wmi/wmi-acpi.mspx, December 4, 2001.
HISTORYThe acpiwmi device driver appeared in NetBSD 6.0.
AUTHORS<firstname.lastname@example.org> wrote acpiwmi and most of the mappings.
CAVEATSWhile WMI should provide a certain degree of portability across laptop models from a particular vendor, there is no guarantee that the mappings are functional in all models.
The wmihp driver may conflict with hpqlb(4).
|November 1, 2012||NetBSD 7.0|