Manual browser: irda(4)
|IRFRAME(4)||Kernel Interfaces Manual||IRFRAME(4)|
NAMEirframe — IrDA frame level driver
SYNOPSISirframe* at oboe?
irframe* at udsir?
irframe* at uirda?
irframe* at ustir?
DESCRIPTIONThe irframe driver provides support for IrDA frame level transmission. It does not contain the IrDA protocol stack per se, but the stack can be built on top of the irframe driver.
Access to frames is via the read(2) and write(2) system calls. Each write constitutes one frame, and each read yields one frame. The poll(2) system call can be used to check for availability of frames. There are also a number of ioctl(2) calls to manipulate the device:
- Reset the parameters set by IRDA_SET_PARAMS.
- IRDA_SET_PARAMS (struct irda_params)
- Set the speed, extra beginning of frame bytes, and maximum frame size.
- IRDA_GET_SPEEDMASK (int)
- Get the set of allowable speeds.
- IRDA_GET_TURNAROUNDMASK (int)
- Get the set of allowable turn around times.
HISTORYThe irframe driver appeared in NetBSD 1.6.
|December 2, 2001||NetBSD 7.0|